Blog

Heartbleed bug and W3 Total Cache

By now, you’ve no doubt read posts from all over the web about the Heartbleed Bug. If you’ve somehow missed the news, here’s a quick overview:

The Heartbleed Bug is a serious vulnerability in the popular OpenSSL cryptographic software library. This weakness allows stealing the information protected, under normal conditions, by the SSL/TLS encryption used to secure the Internet. SSL/TLS provides communication security and privacy over the Internet for applications such as web, email, instant messaging (IM) and some virtual private networks (VPNs).
The Heartbleed bug allows anyone on the Internet to read the memory of the systems protected by the vulnerable versions of the OpenSSL software. This compromises the secret keys used to identify the service providers and to encrypt the traffic, the names and passwords of the users and the actual content. This allows attackers to eavesdrop on communications, steal data directly from the services and users and to impersonate services and users.

Pretty scary stuff.

How it affects you

Here at W3 EDGE, and we use SSL to secure credit card transactions when customers purchase W3 Total Cache Pro license through the WordPress dashboard.

Upon learning of the bug, we upgraded OpenSSL on our servers to version 1.0.1g which was released on Monday and contains a patch for the Heartbleed bug. No action is required on your part, and you can continue using W3 Total Cache with confidence.

Subscribe to W3 EDGE Updates

This entry was posted on and is filed under News. You can follow any responses to this entry through the RSS 2.0 feed.

Comments are closed.